Kotlin 1.5.0-M2 发布:确保顺利迁移到 Kotlin 1.5.0

Kotlin 1.5.0 即将在今年春天发布,而 Kotlin 1.5.0-M2 是其的最后一个里程碑版本。因此,这将是您确保您的项目可以在 Kotlin 1.5.0 下正常工作的最后机会——再不行动,正式版就要来啦!

Install 1.5.0-M2

您可以立即迁移您的项目,这样等将来新版本正式发布时您就不必再耗费精力来做迁移了。实际上,在 Kotlin 1.5.0 发版之前,您还可以为我们在修复紧急问题时提供必要的帮助。

例如,如果您在试用1.5.0 默认的新 JVM IR 后端编译器时发现了问题,我们会尽力去在正式发布之前进行修复。您可以将您遇到的问题发布到 YouTrack 方便我们跟踪和解决。需要说明的是,因此如果您已经在使用 Jetpack Compose,那么您已经成为了这个新的后端编译器的用户,因为Jetpack Compose 依赖于它。

更简单的预览版本集成配置

在之前,您如果想要在现有的项目当中集成 Kotlin 的预览版本,您需要在 Gradle 配置当中额外地添加一个 Bintray 的仓库。现在不用那么麻烦了,所有的构件都发布到了 Maven 中央仓库(译者注:说来也逗,这大概是为了应对 Bintray 的下线吧)。

在 IntelliJ IDEA 当中安装 M2 版本,并将项目当中的 Kotlin 版本修改成 1.5.0-M2,如果需要的话,再稍微调整一下依赖就可以了。

Install 1.5.0-M2

分享您的真实案例

您是否曾尝试过我们在 Kotlin 1.4.30 当中发布的实验特性?

如果还没有,那赶紧试试看吧!如果您已经在使用这些特性,那一定有很好的用例可以分享吧,千万不要吝啬,来来来,秀出来!

您的分享对我们的帮助将会很大,因为我们的文档团队经常收到这样的反馈 🗣:

“添加点儿案例吧!”.

“在真实的项目当中不知道该咋用”.

“能提供写详细的案例和使用说明吗?”

所以,我们希望大家能够帮我们贡献各类生产环境中的真实案例,以使我们的文档更加丰富完善并最终帮助到所有的开发者们。

Share a language feature sample

不要错过 Kotlin 1.5.0 视频

Kotlin YouTube 频道 已经开通,喜欢看视频的开发者们一定要来关注我们!我们将持续在这个频道更新视频,并计划发布一系列介绍 Kotlin 1.5.0 的专题视频。 千万不要错过 🎥!

Subscribe to Kotlin YouTube


您还没有验证过 Kotlin 1.5.0 与您的项目是否兼容吗? 抓紧时间安装 1.5.0-M2试试,以后就可以高枕无忧啦!

此条目发表在官方分类目录,贴了, , 标签。将固定链接加入收藏夹。

发表评论

邮箱地址不会被公开。 必填项已用*标注